Our express partner will perform scheduled system maintenance from 19th Jan to 3rd Feb, so during this time, all the orders in our webshop will be handled from 4th Feb.
Sorry for any inconvenience caused.

Search found 219 matches

by kuafu
Thu Feb 20, 2020 1:47 am
Forum: Questions & Answers
Topic: ALG_EC_PACE_GM
Replies: 3
Views: 214

Re: ALG_EC_PACE_GM

It's just didn't support on simulater.
But we have card which support it.
You can using this applet test.
viewforum.php?f=30
by kuafu
Wed Feb 19, 2020 2:15 am
Forum: Questions & Answers
Topic: ALG_EC_PACE_GM
Replies: 3
Views: 214

Re: ALG_EC_PACE_GM

The simulator didn't support ALG_EC_PACE_GM .You can build with JCIDE,but can't debug it.
by kuafu
Thu Feb 13, 2020 1:30 am
Forum: User Guide
Topic: How to set Jar container.
Replies: 1
Views: 2043

Re: How to set Jar container or change jc kit

微信截图_20200213132625.png
by kuafu
Mon Jan 27, 2020 11:14 am
Forum: Questions & Answers
Topic: Why JCIDE Build returns error on Signature.ALG_RSA_SHA_256?
Replies: 2
Views: 424

Re: Why JCIDE Build returns error on Signature.ALG_RSA_SHA_256?

Why JCIDE Build returns error on Signature.ALG_RSA_SHA_256 while I am using the final version of JCIDE which supports Java Card Kit 3.0.4? Is there anything to set? Should I do anything except installing proper Javacard Kit and last version of JCIDE? https://www.javacardos.com/javacardforum/viewtop...
by kuafu
Wed Jan 22, 2020 12:34 am
Forum: Questions & Answers
Topic: how to make JCIDE support NXP card.
Replies: 19
Views: 1228

Re: how to make JCIDE support NXP card.

Hello, I could install the CAP file that you sent with snooper download tool. install_successful.PNG But, how can I verify if it is successfully installed or not? Because when I am trying to select applet in pyAPDU tool after installing the applet, it still gives below error Select Applet error: gl...
by kuafu
Tue Jan 21, 2020 11:24 am
Forum: Questions & Answers
Topic: how to make JCIDE support NXP card.
Replies: 19
Views: 1228

Re: how to make JCIDE support NXP card.

I think you need to change another download tool to find out the problem. You can try this tool http://www.microissuer.com/index_en.html
by kuafu
Tue Jan 21, 2020 10:54 am
Forum: Questions & Answers
Topic: how to make JCIDE support NXP card.
Replies: 19
Views: 1228

Re: how to make JCIDE support NXP card.

priyankap wrote:
Mon Jan 20, 2020 12:15 pm
I am quite new to Java Applet development. JAVACOS JCIDE and pyADU are the only tools I have used until now.

I don't have JCOP tool. Can I download it from somewhere or I should buy from NXP?
test.zip
This is test applet genreate by jcop tool ,can you try it.
by kuafu
Mon Jan 20, 2020 12:04 pm
Forum: Questions & Answers
Topic: how to make JCIDE support NXP card.
Replies: 19
Views: 1228

Re: how to make JCIDE support NXP card.

Using jcop tool to gen cap file , and try to load it. It the way.
by kuafu
Mon Jan 20, 2020 11:26 am
Forum: Questions & Answers
Topic: how to make JCIDE support NXP card.
Replies: 19
Views: 1228

Re: how to make JCIDE support NXP card.

sorry. same post got sent twice. so deleted this one. I try to upload walt applet with jcop tool , it can upload ,but install fauled. 1.png Then i creat a hello applet ,it can upload ,and install sucesssful. 2.png Can you try this hello appet.If it work ,then it's no about the tool ,it's about the ...
by kuafu
Sun Jan 19, 2020 8:34 am
Forum: Questions & Answers
Topic: How can I use Java_card_3.0.1 and Global Platform 2.2.1 with JCKit JAVACOS_3.0.1.3?
Replies: 1
Views: 196

Re: How can I use Java_card_3.0.1 and Global Platform 2.2.1 with JCKit JAVACOS_3.0.1.3?

I want to generate a CAP file for my java applet which I need to install on NXP J2E081 JCOP v2.4.2 R3 80 KB (JavaCard 3.0.1 Classic) . I am currently using JCKit JAVACOS_3.0.1.3 which supports java_card_3.0.4 and java_card_3.0.5 but I want to generate a CAP file for java_card_3.0.1 and also I need ...
JavaCard OS : Disclaimer