Christmas is coming! To thank for the support from all our dear customers, Christmas promotional activity is going on in JavaCardOS Online Store
Please check this post to know more. Don't Miss Our Best Prices!

Error when debugging my applet in JCIDE

JCIDE related questions and answers.

Moderators: product, kuafu

Sajaki
Posts: 11
Joined: Tue Jan 05, 2016 4:51 am
Points :106
Contact:

Error when debugging my applet in JCIDE

Post by Sajaki » Wed Sep 07, 2016 2:00 am

When I click Debug button to debug my applet in JCIDE, I always got an error "Connect CL port failed .Please disconnect JAVACOS Virtual Contact Reader 0 first" in debug shell. How can I solve this issue? Does anyone know?

You do not have the required permissions to view the files attached to this post. Please login first.

User avatar
lostsiwonlw
Posts: 55
Joined: Fri Jul 31, 2015 9:09 pm
Points :358
Contact:

Re: Error when debugging my applet in JCIDE

Post by lostsiwonlw » Wed Sep 07, 2016 3:54 am

What are the following APDU commands used to do?
You do not have the required permissions to view the files attached to this post. Please login first.
Searching for meaning...

Sajaki
Posts: 11
Joined: Tue Jan 05, 2016 4:51 am
Points :106
Contact:

Re: Error when debugging my applet in JCIDE

Post by Sajaki » Wed Sep 07, 2016 5:26 am

I didn't send any commands yet. I thought these were sent by JCIDE.

popmun09
Posts: 36
Joined: Tue Feb 16, 2016 9:49 pm
Points :230
Contact:

Re: Error when debugging my applet in JCIDE

Post by popmun09 » Thu Sep 08, 2016 2:17 am

These unknown commands were sent by your computer OS, which has automatically connected the virtual reader and send APDU commands to it.

To solve your problem, just edit computer policies.

Step1. Launch gpedit.msc

Step2. Select Computer Configuration --> Administrative Templates --> Windows Components --> Smart Card

Step3. Disable Smartcard setting options:
> Turn on certificate propagation from smart card: disable
> Turn on root certificate propagation from smart card: disable
> Force the reading of all certificates from the smart card: disable
> Turn on Smart Card Plug and Play service: disable

You do not have the required permissions to view the files attached to this post. Please login first.

popmun09
Posts: 36
Joined: Tue Feb 16, 2016 9:49 pm
Points :230
Contact:

Re: Error when debugging my applet in JCIDE

Post by popmun09 » Thu Sep 08, 2016 2:19 am

After you edit the policies, remember to restart your computer.

Sajaki
Posts: 11
Joined: Tue Jan 05, 2016 4:51 am
Points :106
Contact:

Re: Error when debugging my applet in JCIDE

Post by Sajaki » Thu Sep 08, 2016 4:03 am

Thanks for all the answers.

@popmun09, I have solved this problem according to your steps. Thanks very much.

typelogic
Posts: 4
Joined: Fri Oct 18, 2019 8:54 am
Points :54
Contact:

Re: Error when debugging my applet in JCIDE

Post by typelogic » Tue Nov 26, 2019 4:07 am

I did this gpedit.msc, but still have the error message in JCIDE. Any tips? JCIDE 3013

Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 4 guests

JavaCard OS : Disclaimer