Bug: Javacard 3.0.4 SDK mismatch

JCIDE related questions and answers.

Moderators: product, kuafu

kosullivan
Posts: 30
Joined: Mon Jun 29, 2015 9:03 pm
Points :450
Contact:

Bug: Javacard 3.0.4 SDK mismatch

Post by kosullivan » Mon Jun 22, 2020 12:32 am

Hi folks,

I recently attempted to switch a project from JC2.2.2 to JC3.0.4. Recompiling worked fine until I tried to add some features that weren't available until 3.0.4, specifically, to use the Applet.reselectingApplet() method.

The compiler failed saying that the method didn't exist. I checked the SDK export and lib files that come with JCKit and it confirmed the method wasn't there. I managed to fix the problem by downloading the JC3.0.4 and replacing the export folder and the lib/api_classic.jar file.

This indicates that there is a version problem with the default install of 3.0.4 on JCKit. Something to look into!

Thanks,
kosul

kuafu
Posts: 291
Joined: Thu Jun 25, 2015 2:09 am
Points :3709
Contact:

Re: Bug: Javacard 3.0.4 SDK mismatch

Post by kuafu » Mon Jun 22, 2020 2:04 am

Can you tell me whick version of JCKit?
well

kuafu
Posts: 291
Joined: Thu Jun 25, 2015 2:09 am
Points :3709
Contact:

Re: Bug: Javacard 3.0.4 SDK mismatch

Post by kuafu » Mon Jun 22, 2020 2:59 am

kosullivan wrote:
Mon Jun 22, 2020 12:32 am
Hi folks,

I recently attempted to switch a project from JC2.2.2 to JC3.0.4. Recompiling worked fine until I tried to add some features that weren't available until 3.0.4, specifically, to use the Applet.reselectingApplet() method.

The compiler failed saying that the method didn't exist. I checked the SDK export and lib files that come with JCKit and it confirmed the method wasn't there. I managed to fix the problem by downloading the JC3.0.4 and replacing the export folder and the lib/api_classic.jar file.

This indicates that there is a version problem with the default install of 3.0.4 on JCKit. Something to look into!

Thanks,
kosul
Try to compile with ECJ. It will no a problem.
well

kuafu
Posts: 291
Joined: Thu Jun 25, 2015 2:09 am
Points :3709
Contact:

Re: Bug: Javacard 3.0.4 SDK mismatch

Post by kuafu » Mon Jun 22, 2020 6:24 am

kosullivan wrote:
Mon Jun 22, 2020 12:32 am
Hi folks,

I recently attempted to switch a project from JC2.2.2 to JC3.0.4. Recompiling worked fine until I tried to add some features that weren't available until 3.0.4, specifically, to use the Applet.reselectingApplet() method.

The compiler failed saying that the method didn't exist. I checked the SDK export and lib files that come with JCKit and it confirmed the method wasn't there. I managed to fix the problem by downloading the JC3.0.4 and replacing the export folder and the lib/api_classic.jar file.

This indicates that there is a version problem with the default install of 3.0.4 on JCKit. Something to look into!

Thanks,
kosul
I add some JC2.2.2 attach file into jc3.0.4 jar. When compile with ECJ , it's no a problem. But compile with javac , it will be a problem. New version i will separate attach source with jar file. Then it wouln't a problem to javac.
well

kosullivan
Posts: 30
Joined: Mon Jun 29, 2015 9:03 pm
Points :450
Contact:

Re: Bug: Javacard 3.0.4 SDK mismatch

Post by kosullivan » Mon Jun 22, 2020 7:23 am

Just to confirm I'm on the latest JCKit 5.0.1.7.

kuafu
Posts: 291
Joined: Thu Jun 25, 2015 2:09 am
Points :3709
Contact:

Re: Bug: Javacard 3.0.4 SDK mismatch

Post by kuafu » Mon Jul 13, 2020 7:42 pm

kosullivan wrote:
Mon Jun 22, 2020 7:23 am
Just to confirm I'm on the latest JCKit 5.0.1.7.
We had fix the problem in the latest verision.
well

kosullivan
Posts: 30
Joined: Mon Jun 29, 2015 9:03 pm
Points :450
Contact:

Re: Bug: Javacard 3.0.4 SDK mismatch

Post by kosullivan » Tue Jul 14, 2020 7:42 pm

kuafu wrote:
Mon Jul 13, 2020 7:42 pm
We had fix the problem in the latest verision.
Wonderful thanks!

elpresidente86
Posts: 2
Joined: Sat Jul 11, 2020 12:28 pm
Points :32
Contact:

Re: Bug: Javacard 3.0.4 SDK mismatch

Post by elpresidente86 » Tue Jul 14, 2020 10:18 pm

kosullivan wrote:
Tue Jul 14, 2020 7:42 pm
kuafu wrote:
Mon Jul 13, 2020 7:42 pm
We had fix the problem in the latest verision.
Wonderful thanks!
hi there kosullivan i was wondering if you could help me with some troubles im having.

kosullivan
Posts: 30
Joined: Mon Jun 29, 2015 9:03 pm
Points :450
Contact:

Re: Bug: Javacard 3.0.4 SDK mismatch

Post by kosullivan » Fri Jul 24, 2020 9:33 am

I'm not sure elpresidente86 but ask away

Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 2 guests

JavaCard OS : Disclaimer