Change JCKit version in JCIDE

JCIDE related questions and answers.

Moderators: product, kuafu

pitbar
Posts: 21
Joined: Wed Dec 02, 2015 5:39 am
Points :89
Contact:

Change JCKit version in JCIDE

Post by pitbar » Sun Oct 23, 2016 11:17 pm

Where can I change Java Card Kit version in JCIDE? I want to compile the applet with lower version in order to adapt to my card.
thx

User avatar
mabel
Posts: 237
Joined: Mon May 18, 2015 3:09 am
Points :1701
Contact:

Re: Change JCKit version in JCIDE

Post by mabel » Mon Oct 24, 2016 1:38 am

In JCIDE, from the menu, select " Build-> Property ", a dialog box "Property Sheet" will pop up. Click "Local JCKit Configuration" in the side bar, and unfold "JCKit Option" and for first item "Java Card kit version", select java_card_kit version from dropdown list.

You do not have the required permissions to view the files attached to this post. Please login first.

initialdhi
Posts: 7
Joined: Mon Oct 03, 2016 4:10 am
Points :96
Contact:

Re: Change JCKit version in JCIDE

Post by initialdhi » Sat Nov 05, 2016 12:22 pm

thank mabel,
I already change my jc kit version with this options,
but the version only for jc 2.2.2, jc 2.1.2, jc 2.1.1
how I can add the library for jc 3.0.1 ++ ?

User avatar
mabel
Posts: 237
Joined: Mon May 18, 2015 3:09 am
Points :1701
Contact:

Re: Change JCKit version in JCIDE

Post by mabel » Sun Nov 06, 2016 10:39 pm

initialdhi wrote:thank mabel,
I already change my jc kit version with this options,
but the version only for jc 2.2.2, jc 2.1.2, jc 2.1.1
how I can add the library for jc 3.0.1 ++ ?


You can try to select jc3.0.4 firstly and compile your applet to get CAP file. Then upload this CAP to see whether it can be successful.

You do not have the required permissions to view the files attached to this post. Please login first.

User avatar
mabel
Posts: 237
Joined: Mon May 18, 2015 3:09 am
Points :1701
Contact:

Re: Change JCKit version in JCIDE

Post by mabel » Sun Nov 06, 2016 10:45 pm

If the method above is not feasible, you may need to use converter of JCDK3.0.1 to convert the class file and get the CAP file.

initialdhi
Posts: 7
Joined: Mon Oct 03, 2016 4:10 am
Points :96
Contact:

Re: Change JCKit version in JCIDE

Post by initialdhi » Sun Nov 06, 2016 11:42 pm

ooh my JCIDE is old version.
okay I already get *.cap for 3.0.4 but my card is jc3.0.1 and it still not work when install that cap.
so where I get converter of JCDK3.0.1 ??

thk

User avatar
mabel
Posts: 237
Joined: Mon May 18, 2015 3:09 am
Points :1701
Contact:

Re: Change JCKit version in JCIDE

Post by mabel » Sun Nov 06, 2016 11:55 pm

Do you mean you can upload CAP file into your card without any problem?

initialdhi
Posts: 7
Joined: Mon Oct 03, 2016 4:10 am
Points :96
Contact:

Re: Change JCKit version in JCIDE

Post by initialdhi » Mon Nov 07, 2016 5:20 am

sorry
I means I still have any problem when upload cap file jc 3.0.4 in my card that version is jc 3.0.1

User avatar
mabel
Posts: 237
Joined: Mon May 18, 2015 3:09 am
Points :1701
Contact:

Re: Change JCKit version in JCIDE

Post by mabel » Mon Nov 07, 2016 5:58 am

initialdhi wrote:sorry
I means I still have any problem when upload cap file jc 3.0.4 in my card that version is jc 3.0.1


May I have your card type/model?

initialdhi
Posts: 7
Joined: Mon Oct 03, 2016 4:10 am
Points :96
Contact:

Re: Change JCKit version in JCIDE

Post by initialdhi » Mon Nov 07, 2016 6:28 am

NXP J5C145 with JCOP2.4.2 R1 on Java Card 3.0.1 and on the global platform 2.2.1

Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 6 guests

JavaCard OS : Disclaimer